Categories

Vendors

Paramiko 2.2, Cryptography 1.8 and MySQL Workbench

Published on 2017-06-18 at 22:23:24 by  Georgi Sotirov

Like last December I have again omitted some new requirements for Paramiko 2.2 and Cryptography 1.8, so the functionality for SSH connections in MySQL Workbench was unfortunatelly broken again. Apparently, Parmiko 2.2.0 requires bcrypt and PyNaCl modules and in Cryptography 1.8 the module PyASN1 was replaced with asn1crypto. Since I'm trying to provide all the necesary dependncies I had to add 3 new packages to the SlackPack repository, so the depdency tree for Paramiko has effectively become:

Thus it's now necesary to install 3 Python pacakges more just for having SSH connections working in MySQL Workbench, but this should be handled by automtic tools.

Be happy!

Calendar